Posts Tagged ‘Firmware’

PocketWizard Major ControlTL Firmware Update

Free update provides compatibility with several new cameras and dramatic improvements to HyperSync®, further removing the barrier to x-sync limitations. 

So. Burlington, VT – June 12, 2013 – LPA Design, manufacturers of PocketWizard Photo Products, the world leader in wireless control of cameras, flash lighting and light meters, announces today a major update to its ControlTL firmware for the MiniTT1®FlexTT5®PowerMC2 and PowerST4 radios and minor updates for the Plus® III and MultiMAX® radios.

The new ControlTL firmware (version details below) provides compatibility for several new Canon and Nikon cameras, greatly improves the performance of PocketWizard’s exclusive HyperSync feature and resolves bugs in previous versions. It is available now as a free download using the PocketWizard Utility and it is strongly recommended that all current owners of the MiniTT1, FlexTT5, PowerST4 and PowerMC2 update all their radios to the latest firmware for best performance. Any current owner of the ControlTL system can easily install this version via USB connection and update their PocketWizard radios for free. Complete details are available at the PocketWizard site here.

The new firmware includes complete compatibility for the Nikon D600 and D3200 cameras and manual power control compatibility for the Canon EOS 6D, EOS-1D X and EOS Rebel T4i cameras.

1081new_me.jpg

In addition to the new camera compatibility, this new firmware version offers significantly improved HyperSync flash performance. This exclusive feature offers photographers the ability to use studio flash well beyond their camera’s normal x-sync speed, for greatly expanded creative control.

(more…)

Bookmark and Share

PocketWizard Plus III Firmware Update!

The PocketWizard Plus III, one of the most popular models in our current line of products, has new firmware available in the form of version 1.200!

PocketWizard Plus IIIOne of the most noticeable differences to be found in the new firmware is the new system to monitor battery level. In our previous firmware, battery level was conveyed solely by color, but in firmware revision 1.200 we have changed this to be more intuitive and even easier to read. Now when the battery is between full and fifty percent the Status LED will blink green once, when between fifty and twenty-five percent the Status LED will blink amber twice, and when below twenty-five percent the Status LED will blink red three times.

Along with the improved battery indicator we have also made adjustments that improve communications between the Plus III and the MultiMax as well as improved compatibility with several older flash models. To read about these changes read the Plus III Firmware 1.200 release notes.

To update your radio simply plug your radio via USB into your computer and open the latest PocketWizard Utility (version 1.54) and the option to update will come up automatically. If you do not have the latest PocketWizard Utility, find it on our Downloads page.

Bookmark and Share

ControlTL Firmware Update for Canon 5D Mark III Released

PocketWizard® Photo Products Announces ControlTL® Firmware Update for Canon EOS 5D Mark III. The update provides compatibility for Canon version MiniTT1® and FlexTT5® radios with the Canon 5D Mark III digital SLR camera. The following is the official press release.

Flex TT5 Mini TT1So. Burlington, VT – December 19, 2012 – LPA Design, manufacturers of PocketWizard Photo Products, the world leader in wireless control of cameras, flash lighting and light meters, announces today a new update to its ControlTL firmware for Canon versions of its MiniTT1 and FlexTT5 radios. Available now, firmware version 6.200 for Canon includes compatibility with the Canon 5D Mark III digital SLR camera. Any current owner of the ControlTL system can easily install this version via USB connection and update for free using the PocketWizard Utility. PocketWizard Utility version 1.54 or later is required before installing this update.

“This latest release of ControlTL firmware further strengthens PocketWizard’s compatibility with the Canon brand of digital cameras and flashes,” said Dave Schmidt, Vice President of Marketing at LPA Design, the company that manufacturers PocketWizard Photo Products. “Our engineers worked tirelessly to make this update available to our customers that use the Canon 5D Mark III camera. Our goal is to provide photographers with frequent important upgrades such as this because it allows owners of PocketWizard radios to stay current as new cameras and flash units are introduced.”

Compatibility for the Canon EOS-1D X is not available at this time, but firmware for this camera should be available in the near future. Learn more about our firmware development plan.

Visit the PocketWizard download page for more information on how to update PocketWizard products via USB connection.

Bookmark and Share

PocketWizard Releases Utility 1.54 & 1.55

PocketWizard Utility 1.45 and 1.55

pocketwizard.com

If you haven’t done so yet, head over to the PocketWizard site to download the latest version of our Utility software, which allows you to download any firmware updates we offer in the future.

From the press release:

Utility version 1.54 and 1.55 offers a few new features from Utility 1.35 including the ability to upgrade your PocketWizard Plus® III with future firmware updates.

Utility 1.54 and 1.55 offer many improvements including improved help text, automatic notifications for new firmware and the addition of a scrollbar to the inner frame allowing for better full screen operations on smaller displays. Additionally, a final version for PowerPC-based Macs running Mac OS X version 10.5 (“Leopard”) was created.

Read the press release, the release notes (PDF), and go to the downloads page to get started.

Bookmark and Share

Beta Firmware Release for Canon 5D Mark III Compatibility

So. Burlington, VT – August 31, 2012: LPA Design, manufacturers of PocketWizard Photo Products, the world leader in wireless control of cameras, flash lighting and light meters, announces today the release of PocketWizard MiniTT1 and FlexTT5 for Canon 6.153 beta firmware with Canon EOS 5D Mark III compatibility.

The beta firmware release notes and instructions on how to download the beta firmware can be found here.

Please note this beta firmware release for Canon does not include compatibility with the Canon EOS-1D X or the Rebel T4i.

Although feedback from our user base via social media has been overwhelmingly positive at this point, please note this is a beta release and not an official firmware release.

Learn more about our firmware development plan.

Bookmark and Share

PocketWizard Photo Products Announces ControlTL Firmware Update

Today a new firmware update has been issued. Please read the press release below for full details.

 

New features and free upgrades available now for MiniTT1® and FlexTT5® radios, both Canon and Nikon versions

So. Burlington, VTAugust 6, 2012 – LPA Design, manufacturers of PocketWizard Photo Products, the world leader in wireless control of cameras, flash lighting and light meters, announces today a new update to its ControlTL firmware for both Nikon and Canon versions of its MiniTT1 and FlexTT5 radios. Available now, version 3.150 for Nikon and Version 6.150 for Canon include several new features and updates including compatibility with more cameras and flash units, added support for the Sekonic RT-32CTL module, and new optimized rear curtain sync utility control. Any current owner of the ControlTL system can easily install these new features via USB connection and update for free using the PocketWizard Utility.

“This latest release of ControlTL firmware further strengthens PocketWizard’s compatibility with Nikon and Canon brand digital cameras and flashes,” said Dave Schmidt, Vice President of Marketing at LPA Design, the company that manufacturers PocketWizard photo products. “Providing photographers with frequent important upgrades such as this is a very high priority for us because it allows owners of PocketWizard radios to stay current as new cameras and flash units are introduced.”

New firmware features include compatibility with the Nikon D4, D800 and D800E digital cameras and Nikon SB-910 Speedlight as well as compatibility with the Canon 600 EX-RT Speedlite and ST-E3-RT Speedlite Transmitter. Compatibility for the Canon 5D Mark III is not available at this time but firmware for this camera should be available in the near future.

PocketWizard’s MiniTT1 and FlexTT5 radios require this firmware update to work with Sekonic light meters with the RT-32CTL module in ControlTL mode. Using this module, compatible Sekonic light meters can trigger ControlTL radios receiving on ControlTL channels. This allows photographers to use an AC3 ZoneController on their transmitting MiniTT1or FlexTT5 to set their remote flash power levels, and then meter those remote flashes using their compatible Sekonic light meter, all wirelessly within the ControlTL system. More information can be found here.

These two firmware releases also include many additional operational improvements including improved default Aperture Priority combined with Rear Curtain Sync operation, improved Pre-Flash operation across all zones (Nikon), and more.

More information on how to update PocketWizard products via USB connection can be found here.

MiniTT1 and FlexTT5 Firmware Release Notes for Canon (6.150).

MiniTT1 and FlexTT5 Firmware Release Notes for Nikon (3.150).

Bookmark and Share

Firmware 5.15 Corrects Data Table Issue in 5.10

We recently released the latest official ControlTL firmware, version 5.10. Based on continued internal testing and feedback from users, it appears a couple of the exposure and timing data tables became corrupted somewhere in the process. We’ve had reports of improper exposures with several camera models as well as shutter clipping with the Canon 1Ds Mark III and 1D Mark IV. We have corrected the tables and the revised firmware is available as version 5.15 and can be downloaded via the PocketWizard Utility now.

We recommend upgrading to 5.15 as soon as you can.

The manual addendum for v5.10 is still the same for v5.15.

Bookmark and Share